Hey! raylib forum is closing!

After a year with not much movement in the forum I decided to close it.

The cost of maintaining the hosting is a bit high for the usage of the platform, updating the forum and managing it is also a bit cumbersome and the truth is that I'm already trying to maintain multiple other networks pretty more active than this forum.

I'll recommend you to move to the other raylib networks:

- For a forum style, use Reddit: https://www.reddit.com/r/raylib/
- For direct messaging and questions, use Discord: https://discord.gg/VkzNHUE
- To report issues, use GitHub: https://github.com/raysan5/raylib

- Also, remember you can contact me personally on Twitter: https://twitter.com/raysan5 or directly by mail to ray[at]raylib.com

If you feel generous, you can also contribute to the project on my Patreon: https://www.patreon.com/raylib

Thanks to you all for joining the project and help to improve it with your questions. Keep it up! :)

Best Regards,

Ray

PD. Closing will be effective by October 31th.

Cannot compile raylib core or run compiled program.

edited October 2017 in raylib: core
Wanted to finish my little game made in this framework.
So, downloading installer, running it and setting up include path in IDE (Eclipse).
As soonest as i started to compile, these errors poped up:

undefined reference to 'InitWindow'

Same for : SetTargetFPS,WindowShouldClose,BeginDraw,EndDraw

Trying to fix this issue i heve tested if compiling will work in configured Notepad++. Yes it compiles but cannot run program.
Compiling core gives these errors:
https://gist.github.com/BlackDiamondPL/41cbfde3d4ed0204e4690dafd7995b6f

Weird, i am using MinGW's includes to compile, but it searches for Cygwin's.

Comments

  • edited October 2017
    Removed Cygwin from system path, still same result.
    ccLIDkMp.o:main.cpp:(.text+0x2c): undefined reference to `InitWindow'
    ccLIDkMp.o:main.cpp:(.text+0x38): undefined reference to `SetTargetFPS'
    ccLIDkMp.o:main.cpp:(.text+0x3d): undefined reference to `WindowShouldClose'
    ccLIDkMp.o:main.cpp:(.text+0x4e): undefined reference to `BeginDrawing'
    ccLIDkMp.o:main.cpp:(.text+0x71): undefined reference to `ClearBackground'
    ccLIDkMp.o:main.cpp:(.text+0x7b): undefined reference to `EndDrawing'
    ccLIDkMp.o:main.cpp:(.text+0x8c): undefined reference to `CloseWindow'

    Edit: Ok i can compile core but still udefined references are all over the place
    Edit 2: Undefined references fixed. Now it cannot find core libraries.
  • Hi BlackDiamondPL,

    It seems there is some problem with library linking... Have you tried with Visual Studio project?

    Have you tried downloading latest version from raylib GitHub? Multiple issues have been solved...
  • I don't have Visual Studio, but i have Visual Studio Code, so it's not better. Installed NetBeans. Added include path and the same problem appears. I have updated raylib from Github.
  • And yeah 'Undefined references' are back
Sign In or Register to comment.