raylib problems installing for Windows (worked great for the pi)

I have raylib working fantastically on the pi, will post a demo game soon.

Simply cannot get the package to install correctly on Windows 10 however. The installer runs, downloads the folders and files but does not install the expected icons or software as far as I can see. No MinGW app. Cannot find an install.exe in any of the folders for MinGW but think this should have been installed as the installer completed without error and the MinGW files are there. Perhaps I am looking in the wrong place, the application is not installed as a windows app. I have been following the "Compile for Windows" Installing raylib instructions. I ran the installer on the raysan5.itch.io/raylib/download . . . page.

Comments

  • raylib Windows installer installs everything (Notepad++ preconfigured, MinGW compiler and raylib library+examples) in a portable folder in C:\raylib. It's not a Windows app, it's a classic Win32 program.

    A Notepad++ icon should appear on classic Windows desktop, just run it and follow instructions. If the icon does not appear, just go to C:\raylib\Notepad++ and run Notepad++.exe, a sample file should be ready to run just pressing F6.

    No additional dependencies are required, it should be way easier than getting it working on Raspberry pi!
  • Hi chriswoollard

    Did you install the Pi GLES version that does not run in an X Window? Can you give use some details about the Pi model and Raspbian version you are using?
  • Hi,
    I am using a raspberry pi 3 model B rev 1.2
    and debian version 8.0,
    nothing else except of course the raylib download
    Only started using raylib a few days ago and of course updated the pi just before installing raylib. It is working very well indeed on the pi!
Sign In or Register to comment.